# CVE-2022-48115: Cross-site Scripting in jspreadsheet

> An attacker can execute arbitrary scripts in the victim's browser via the dropdown menu in the jspreadsheet library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Feb 2023
- **Updated:** 18 Mar 2025
- **Also known as:** GHSA-q82h-q47j-f492

## What is CVE-2022-48115?

CVE-2022-48115 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The dropdown menu in jspreadsheet before v4.6.0 was discovered to be vulnerable to cross-site scripting (XSS).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-48115?

2 open source packages ship an affected version, including jspreadsheet-ce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jspreadsheet-ce` | npm | All versions | 4.6.0 |
| `jspreadsheet-ce` | npm | All versions | 4.6.0 |

Products: Jspreadsheet Jspreadsheet.

## How do I fix CVE-2022-48115?

Upgrade jspreadsheet-ce to 4.6.0 or later.

## Is CVE-2022-48115 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-48115 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-48115 and fix it if it is affected.

What it is: CVE-2022-48115 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-48115 exists.

Affected packages and fixed versions:
- jspreadsheet-ce (npm): affected all versions; fixed in 4.6.0
- jspreadsheet-ce (npm): affected all versions; fixed in 4.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-48115/ (Markdown: https://insights.sbomify.com/CVE-2022-48115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-48115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-48115
- OSV: https://osv.dev/vulnerability/CVE-2022-48115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-48115/
Summaries are generated and may contain mistakes; the official description above is the record.
