# CVE-2022-48279: Security feature bypass in n/a

> Attackers can bypass ModSecurity Web Application Firewall protections by sending specially crafted HTTP multipart requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2023
- **Updated:** 3 Apr 2025
- **Also known as:** AZL-43705, AZL-45216, BIT-modsecurity-2022-48279, BIT-modsecurity2-2022-48279, DEBIAN-CVE-2022-48279, GHSA-6fhx-fm6h-hpxq, OESA-2024-1334, OESA-2024-1375, OESA-2024-1376, OESA-2024-1377, OESA-2024-1378, OESA-2024-1512, SUSE-SU-2023:0314-1, SUSE-SU-2023:0317-1, SUSE-SU-2023:0318-1, UBUNTU-CVE-2022-48279, openSUSE-SU-2025:14703-1

## What is CVE-2022-48279?

CVE-2022-48279 is a high-severity vulnerability in Debian Debian Linux, published on 20 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In ModSecurity before 2.9.6 and 3.x before 3.0.8, HTTP multipart requests were incorrectly parsed and could bypass the Web Application Firewall. NOTE: this is related to CVE-2022-39956 but can be considered independent changes to the ModSecurity (C language) codebase.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2022-48279?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modsecurity` | Bitnami | All versions | 2.9.6 |
| `modsecurity2` | Bitnami | All versions | 2.9.6 |
| `apache2-mod_security2` | SUSE:Enterprise Storage 6 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Enterprise Storage 7 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Enterprise Storage 7.1 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 2.9.4-150400.3.3.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server 12 SP2-BCL | All versions | 2.8.0-7.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server 12 SP4-LTSS | All versions | 2.8.0-7.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 2.8.0-7.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 2.8.0-7.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 2.8.0-7.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Manager Proxy 4.2 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Manager Retail Branch Server 4.2 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:Manager Server 4.2 | All versions | 2.9.2-150000.3.6.1 |
| `apache2-mod_security2` | SUSE:OpenStack Cloud 9 | All versions | 2.8.0-7.6.1 |
| `apache2-mod_security2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 2.8.0-7.6.1 |
| `apache2-mod_security2` | openSUSE:Leap 15.4 | All versions | 2.9.4-150400.3.3.1 |
| `apache2-mod_security2` | openSUSE:Tumbleweed | All versions | 2.9.8-2.1 |

Products: Debian Debian Linux, Owasp Modsecurity, Trustwave Modsecurity.

## How do I fix CVE-2022-48279?

Upgrade modsecurity to 2.9.6 or later.

## Is CVE-2022-48279 being exploited?

There is no known exploitation of CVE-2022-48279 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-48279 and fix it if it is affected.

What it is: CVE-2022-48279 is a high-severity vulnerability in Debian Debian Linux, published on 20 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-48279 in the wild and no public exploit code.

Affected packages and fixed versions:
- modsecurity (Bitnami): affected all versions; fixed in 2.9.6
- modsecurity2 (Bitnami): affected all versions; fixed in 2.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-48279/ (Markdown: https://insights.sbomify.com/CVE-2022-48279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-48279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-48279
- OSV: https://osv.dev/vulnerability/CVE-2022-48279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-48279/
Summaries are generated and may contain mistakes; the official description above is the record.
