# CVE-2022-48285: JSZip contains Path Traversal via loadAsync

> Attackers can exploit a directory traversal flaw in JSZip to read or modify arbitrary files via a crafted ZIP archive.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2023
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-38236, AZL-57076, DEBIAN-CVE-2022-48285, GHSA-36fh-84j7-cv5h, UBUNTU-CVE-2022-48285

## What is CVE-2022-48285?

CVE-2022-48285 is a high-severity path traversal vulnerability in n/a, published on 29 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

loadAsync in JSZip before 3.8.0 allows Directory Traversal via a crafted ZIP archive.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-48285?

2 open source packages ship an affected version, including jszip. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jszip` | npm | All versions | 3.8.0 |
| `jszip` | npm | All versions | 3.8.0 |

Products: Jszip Project Jszip.

## How do I fix CVE-2022-48285?

Upgrade jszip to 3.8.0 or later.

## Is CVE-2022-48285 being exploited?

There is no known exploitation of CVE-2022-48285 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-23413](https://insights.sbomify.com/CVE-2021-23413/): Denial of Service (DoS) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-48285 and fix it if it is affected.

What it is: CVE-2022-48285 is a high-severity path traversal vulnerability in n/a, published on 29 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-48285 in the wild and no public exploit code.

Affected packages and fixed versions:
- jszip (npm): affected all versions; fixed in 3.8.0
- jszip (npm): affected all versions; fixed in 3.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-48285/ (Markdown: https://insights.sbomify.com/CVE-2022-48285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-48285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-48285
- OSV: https://osv.dev/vulnerability/CVE-2022-48285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-48285/
Summaries are generated and may contain mistakes; the official description above is the record.
