# CVE-2022-48364: Information disclosure in n/a

> Mastodon moderators' identities are disclosed when approving sensitive status appeals due to missing representative account usage.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2023
- **Updated:** 6 Mar 2025
- **Also known as:** BIT-mastodon-2022-48364, GHSA-mjfv-7q85-fj8m

## What is CVE-2022-48364?

CVE-2022-48364 is a medium-severity vulnerability in n/a, published on 6 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The undo_mark_statuses_as_sensitive method in app/services/approve_appeal_service.rb in Mastodon 3.5.x before 3.5.3 does not use the server's representative account, resulting in moderator identity disclosure when a moderator approves the appeal of a user whose status update was marked as sensitive.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-48364?

1 open source package ship an affected version, including mastodon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mastodon` | Bitnami | From 3.5.0 | 3.5.3 |

Products: Joinmastodon Mastodon.

## How do I fix CVE-2022-48364?

Upgrade mastodon to 3.5.3 or later.

## Is CVE-2022-48364 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-48364 exists.

## Other vulnerabilities in n/a

- [CVE-2023-36460](https://insights.sbomify.com/CVE-2023-36460/): Mastodon vulnerable to arbitrary file creation through media attachments (critical 10.0)
- [CVE-2022-2166](https://insights.sbomify.com/CVE-2022-2166/): Improper Restriction of Excessive Authentication Attempts in mastodon/mastodon (critical 9.8)
- [CVE-2022-24307](https://insights.sbomify.com/CVE-2022-24307/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-21018](https://insights.sbomify.com/CVE-2018-21018/): Auth bypass in n/a (critical 9.8)
- [CVE-2024-23832](https://insights.sbomify.com/CVE-2024-23832/): Mastodon Remote user impersonation and takeover (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-48364 and fix it if it is affected.

What it is: CVE-2022-48364 is a medium-severity vulnerability in n/a, published on 6 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-48364 exists.

Affected packages and fixed versions:
- mastodon (Bitnami): affected from 3.5.0; fixed in 3.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-48364/ (Markdown: https://insights.sbomify.com/CVE-2022-48364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-48364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-48364
- OSV: https://osv.dev/vulnerability/CVE-2022-48364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-48364/
Summaries are generated and may contain mistakes; the official description above is the record.
