# CVE-2022-4847: Incorrectly Specified Destination in a Communication Channel in usememos/memos

> Attackers can exploit incorrect destination specification in communication channels to access internal resources or bypass security controls in the Memos application.

- **Severity:** High 8.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Dec 2022
- **Updated:** 9 Apr 2025
- **Also known as:** GHSA-r7hg-2cpp-8wqq, GO-2022-1264

## What is CVE-2022-4847?

CVE-2022-4847 is a high-severity server-side request forgery vulnerability in Usememos Memos, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Incorrectly Specified Destination in a Communication Channel in GitHub repository usememos/memos prior to 0.9.1.

Weakness: CWE-941 (Incorrectly Specified Destination in a Communication Channel)

## Which versions are affected by CVE-2022-4847?

3 open source packages ship an affected version, including github.com/usememos/memos. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/usememos/memos` | Go | All versions | 0.9.1 |
| `github.com/usememos/memos` | Go | All versions | 0.9.1 |
| `github.com/usememos/memos` | Go | All versions | 0.9.1 |

Products: Usememos Memos.

## How do I fix CVE-2022-4847?

Upgrade github.com/usememos/memos to 0.9.1 or later.

## Is CVE-2022-4847 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4847 exists.

## Other vulnerabilities in Usememos Memos

- [CVE-2025-50738](https://insights.sbomify.com/CVE-2025-50738/): Memos has Cross-Site Scripting (XSS) Vulnerability in Image URLs (critical 9.8)
- [CVE-2025-22952](https://insights.sbomify.com/CVE-2025-22952/): Memos Server-Side Request Forgery (SSRF) (critical 9.8)
- [CVE-2023-0109](https://insights.sbomify.com/CVE-2023-0109/): Stored XSS in usememos/memos (critical 9.8)
- [CVE-2023-4696](https://insights.sbomify.com/CVE-2023-4696/): Improper Access Control in usememos/memos (critical 9.8)
- [CVE-2022-4866](https://insights.sbomify.com/CVE-2022-4866/): Cross-site Scripting (XSS) - Stored in usememos/memos (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4847 and fix it if it is affected.

What it is: CVE-2022-4847 is a high-severity server-side request forgery vulnerability in Usememos Memos, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4847 exists.

Affected packages and fixed versions:
- github.com/usememos/memos (Go): affected all versions; fixed in 0.9.1
- github.com/usememos/memos (Go): affected all versions; fixed in 0.9.1
- github.com/usememos/memos (Go): affected all versions; fixed in 0.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4847/ (Markdown: https://insights.sbomify.com/CVE-2022-4847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4847
- OSV: https://osv.dev/vulnerability/CVE-2022-4847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4847/
Summaries are generated and may contain mistakes; the official description above is the record.
