CVE-2022-48560 Use after free in n/a
A use-after-free vulnerability in the heapq module allows attackers to potentially execute arbitrary code or cause a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-48560?
CVE-2022-48560 is a high-severity use after free vulnerability in Debian Debian Linux, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A use-after-free exists in Python through 3.9 via heappushpop in heapq.
Weakness: CWE-416
Which versions are affected by CVE-2022-48560?
3 open source packages ship an affected version, including libpython, python and python-min. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
libpython Bitnami | All versions | 3.6.11, 3.7.7, 3.8.2 |
python Bitnami | All versions | 3.6.11, 3.7.7, 3.8.2 |
python-min Bitnami | All versions | 3.6.11, 3.7.7, 3.8.2 |
Linux distribution packages (1)
python openSUSE:Tumbleweed | All versions | 2.7.18-41.1 |
Products include Debian Debian Linux, Python Python.
How do I fix CVE-2022-48560?
Upgrade libpython to a fixed version for your release line: 3.6.11, 3.7.7 or 3.8.2.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2022-48560 being exploited?
There is no known exploitation of CVE-2022-48560 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-109647, BIT-libpython-2022-48560, BIT-python-2022-48560, BIT-python-min-2022-48560, CLSA-2023-1696537500, CLSA-2023-1697740469 and 17 more.