{"answers":{"affected":"3 open source packages ship an affected version, including libpython, python and python-min. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-48560 in the wild and no public exploit code.","fix":"Upgrade libpython to a fixed version for your release line: 3.6.11, 3.7.7 or 3.8.2.","what":"CVE-2022-48560 is a high-severity use after free vulnerability in Debian Debian Linux, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-48560 and fix it if it is affected.\n\nWhat it is: CVE-2022-48560 is a high-severity use after free vulnerability in Debian Debian Linux, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-48560 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libpython (Bitnami): affected all versions; fixed in 3.6.11, 3.7.7, 3.8.2\n- python (Bitnami): affected all versions; fixed in 3.6.11, 3.7.7, 3.8.2\n- python-min (Bitnami): affected all versions; fixed in 3.6.11, 3.7.7, 3.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-48560/ (Markdown: https://insights.sbomify.com/CVE-2022-48560/index.md)","id":"CVE-2022-48560","markdown":"https://insights.sbomify.com/CVE-2022-48560/index.md","name":"CVE-2022-48560","record":{"aliases":["AZL-109647","BIT-libpython-2022-48560","BIT-python-2022-48560","BIT-python-min-2022-48560","CLSA-2023-1696537500","CLSA-2023-1697740469","CLSA-2023-1697740683","CLSA-2023-1697741309","CLSA-2023-1697741516","CLSA-2023-1697741983","CLSA-2023-1697816511","CLSA-2023-1698101603","CLSA-2023-1698101835","CLSA-2023-1699468875","CLSA-2023-1702573269","CLSA-2023-1702573728","DEBIAN-CVE-2022-48560","GHSA-pvw5-cvp6-cv92","PSF-2023-11","UBUNTU-CVE-2022-48560","USN-6394-1","USN-6394-2","openSUSE-SU-2024:13488-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python standard library","requires_auth":"none","summary":"A use-after-free vulnerability in the heapq module allows attackers to potentially execute arbitrary code or cause a denial of service.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"python","vendor":"python"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"A use-after-free exists in Python through 3.9 via heappushpop in heapq.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in n/a","id":"CVE-2022-48560","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","python:python"],"type":"use_after_free","year":"2022"},"n_packages":4,"n_references":6,"next":{"headline":"Denial of service in n/a","id":"CVE-2022-48564"},"packages":[{"ecosystem":"Bitnami","fixed":["3.6.11","3.7.7","3.8.2"],"introduced":["0","3.7.0","3.8.0"],"last_affected":[],"package":"libpython","purl":"pkg:bitnami/libpython","source":"BIT-libpython-2022-48560"},{"ecosystem":"Bitnami","fixed":["3.6.11","3.7.7","3.8.2"],"introduced":["0","3.7.0","3.8.0"],"last_affected":[],"package":"python","purl":"pkg:bitnami/python","source":"BIT-python-2022-48560"},{"ecosystem":"Bitnami","fixed":["3.6.11","3.7.7","3.8.2"],"introduced":["0","3.7.0","3.8.0"],"last_affected":[],"package":"python-min","purl":"pkg:bitnami/python-min","source":"BIT-python-min-2022-48560"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.7.18-41.1"],"introduced":["0"],"last_affected":[],"package":"python","purl":"pkg:rpm/opensuse/python\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13488-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2022-48554"},"products":["n/a"],"published":"2023-08-22","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-10-14","vendors":["n/a"]},"summary":"A use-after-free vulnerability in the heapq module allows attackers to potentially execute arbitrary code or cause a denial of service.","url":"https://insights.sbomify.com/CVE-2022-48560/"}