# CVE-2022-48564: Denial of service in n/a

> Attackers can cause CPU and RAM exhaustion in Python applications by processing malformed binary Apple Property List files.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Aug 2023
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-109650, BIT-libpython-2022-48564, BIT-python-2022-48564, BIT-python-min-2022-48564, CLSA-2024-1710437461, DEBIAN-CVE-2022-48564, GHSA-p8vw-m6qq-w42v, PSF-2023-10, UBUNTU-CVE-2022-48564

## What is CVE-2022-48564?

CVE-2022-48564 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

read_ints in plistlib.py in Python through 3.9.1 is vulnerable to a potential DoS attack via CPU and RAM exhaustion when processing malformed Apple Property List files in binary format.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-48564?

3 open source packages ship an affected version, including libpython, python and python-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | All versions | 3.6.13, 3.7.10, 3.8.7, 3.9.1 |
| `python` | Bitnami | All versions | 3.6.13, 3.7.10, 3.8.7, 3.9.1 |
| `python-min` | Bitnami | All versions | 3.6.13, 3.7.10, 3.8.7, 3.9.1 |

Products: Netapp Active Iq Unified Manager, Python Python.

## How do I fix CVE-2022-48564?

Upgrade libpython to a fixed version for your release line: 3.6.13, 3.7.10, 3.8.7 or 3.9.1.

## Is CVE-2022-48564 being exploited?

There is no known exploitation of CVE-2022-48564 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-48564 and fix it if it is affected.

What it is: CVE-2022-48564 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-48564 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected all versions; fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1
- python (Bitnami): affected all versions; fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1
- python-min (Bitnami): affected all versions; fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-48564/ (Markdown: https://insights.sbomify.com/CVE-2022-48564/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-48564
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-48564
- OSV: https://osv.dev/vulnerability/CVE-2022-48564

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-48564/
Summaries are generated and may contain mistakes; the official description above is the record.
