# CVE-2022-48566: Race condition in n/a

> Timing side-channel in Python's hmac.compare_digest allows attackers to bypass constant-time protections and potentially recover secrets.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2023
- **Updated:** 3 Oct 2024
- **Also known as:** AZL-109656, BIT-libpython-2022-48566, BIT-python-2022-48566, BIT-python-min-2022-48566, CLSA-2023-1697462566, CLSA-2023-1697463155, CLSA-2023-1697463705, CLSA-2023-1697464069, CLSA-2023-1697465384, CLSA-2023-1697466063, CLSA-2023-1697556743, DEBIAN-CVE-2022-48566, GHSA-cgfh-jp5w-8cmx, OESA-2023-1639, OESA-2023-1640, PSF-2023-6, UBUNTU-CVE-2022-48566, USN-6400-1

## What is CVE-2022-48566?

CVE-2022-48566 is a medium-severity vulnerability in Debian Debian Linux, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in compare_digest in Lib/hmac.py in Python through 3.9.1. Constant-time-defeating optimisations were possible in the accumulator variable in hmac.compare_digest.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2022-48566?

3 open source packages ship an affected version, including libpython, python and python-min. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | All versions | 3.6.13, 3.7.10, 3.8.7, 3.9.1 |
| `python` | Bitnami | All versions | 3.6.13, 3.7.10, 3.8.7, 3.9.1 |
| `python-min` | Bitnami | All versions | 3.6.13, 3.7.10, 3.8.7, 3.9.1 |

Products: Debian Debian Linux, Netapp Active Iq Unified Manager, Netapp Converged Systems Advisor Agent, Python Python.

## How do I fix CVE-2022-48566?

Upgrade libpython to a fixed version for your release line: 3.6.13, 3.7.10, 3.8.7 or 3.9.1.

## Is CVE-2022-48566 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-48566 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-48566 and fix it if it is affected.

What it is: CVE-2022-48566 is a medium-severity vulnerability in Debian Debian Linux, published on 22 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-48566 exists.

Affected packages and fixed versions:
- libpython (Bitnami): affected all versions; fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1
- python (Bitnami): affected all versions; fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1
- python-min (Bitnami): affected all versions; fixed in 3.6.13, 3.7.10, 3.8.7, 3.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-48566/ (Markdown: https://insights.sbomify.com/CVE-2022-48566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-48566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-48566
- OSV: https://osv.dev/vulnerability/CVE-2022-48566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-48566/
Summaries are generated and may contain mistakes; the official description above is the record.
