# CVE-2022-48614: Cross-site Scripting in Semantic MediaWiki

> Reflected XSS in Semantic MediaWiki allows attackers to execute arbitrary scripts in user browsers, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Dec 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hj4c-vfc4-5f9c, UBUNTU-CVE-2022-48614

## What is CVE-2022-48614?

CVE-2022-48614 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Special:Ask in Semantic MediaWiki before 4.0.2 allows Reflected XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-48614?

2 open source packages ship an affected version, including mediawiki/semantic-media-wiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/semantic-media-wiki` | Packagist | All versions | 4.0.2 |
| `mediawiki/semantic-media-wiki` | Packagist | All versions | 4.0.2 |

Products: Semantic-Mediawiki Semantic Mediawiki.

## How do I fix CVE-2022-48614?

Upgrade mediawiki/semantic-media-wiki to 4.0.2 or later.

## Is CVE-2022-48614 being exploited?

There is no known exploitation of CVE-2022-48614 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-116874](https://insights.sbomify.com/CVE-2026-116874/): SemanticMediaWiki 3.1.0 before 7.3.1 Reflected XSS via JsonResultPrinter Default Parameter (medium 5.3)
- [CVE-2026-116875](https://insights.sbomify.com/CVE-2026-116875/): SemanticMediaWiki 3.0.0 before 7.3.1 Reflected XSS via Special:Ask Separator Parameters (medium 5.3)
- [CVE-2026-116884](https://insights.sbomify.com/CVE-2026-116884/): SemanticMediaWiki 5.0.0 before 7.3.1 Stored XSS via Tooltip Module data-* Attributes (medium 5.3)
- [CVE-2026-116889](https://insights.sbomify.com/CVE-2026-116889/): SemanticMediaWiki 2.5.0 before 7.3.1 Stored XSS via Special:Browse Code Property (medium 5.3)
- [CVE-2026-116892](https://insights.sbomify.com/CVE-2026-116892/): SemanticMediaWiki 3.1.0 before 7.3.1 Reflected XSS via Special:Search smw Profile (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-48614 and fix it if it is affected.

What it is: CVE-2022-48614 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Dec 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-48614 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/semantic-media-wiki (Packagist): affected all versions; fixed in 4.0.2
- mediawiki/semantic-media-wiki (Packagist): affected all versions; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-48614/ (Markdown: https://insights.sbomify.com/CVE-2022-48614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-48614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-48614
- OSV: https://osv.dev/vulnerability/CVE-2022-48614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-48614/
Summaries are generated and may contain mistakes; the official description above is the record.
