{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-48620 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-48620 is a critical memory corruption vulnerability in n/a, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-48620 and fix it if it is affected.\n\nWhat it is: CVE-2022-48620 is a critical memory corruption vulnerability in n/a, published on 12 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-48620 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-48620/ (Markdown: https://insights.sbomify.com/CVE-2022-48620/index.md)","id":"CVE-2022-48620","markdown":"https://insights.sbomify.com/CVE-2022-48620/index.md","name":"CVE-2022-48620","record":{"aliases":["DEBIAN-CVE-2022-48620","DLA-4454-1","GHSA-hjg8-pr7m-gj33","UBUNTU-CVE-2022-48620","openSUSE-SU-2024:0023-1","openSUSE-SU-2024:13578-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"libuev event loop library","requires_auth":"none","summary":"A buffer overflow in libuev's epoll_wait function allows attackers to cause denial of service or execute arbitrary code via large maxevents values.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libeuv","vendor":"troglobit"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"uev (aka libuev) before 2.4.1 has a buffer overflow in epoll_wait if maxevents is a large number.","ecosystems":["SUSE:Package Hub 15 SP5","openSUSE:Leap 15.5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2022-48620","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":2,"n_references":6,"next":{"headline":"Missing authorization in EMUI","id":"CVE-2022-48621"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP5","fixed":["2.4.1-bp155.3.3.1"],"introduced":["0"],"last_affected":[],"package":"libuev","purl":"pkg:rpm/suse/libuev\u0026distro=SUSE%20Package%20Hub%2015%20SP5","source":"openSUSE-SU-2024:0023-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["2.4.1-bp155.3.3.1"],"introduced":["0"],"last_affected":[],"package":"libuev","purl":"pkg:rpm/opensuse/libuev\u0026distro=openSUSE%20Leap%2015.5","source":"openSUSE-SU-2024:0023-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2022-48619"},"products":["n/a"],"published":"2024-01-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-25","vendors":["n/a"]},"summary":"A buffer overflow in libuev's epoll_wait function allows attackers to cause denial of service or execute arbitrary code via large maxevents values.","url":"https://insights.sbomify.com/CVE-2022-48620/"}