{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4876 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-4876 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-4876 is a low-severity cross-site scripting vulnerability in Kaltura mwEmbed, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4876 and fix it if it is affected.\n\nWhat it is: CVE-2022-4876 is a low-severity cross-site scripting vulnerability in Kaltura mwEmbed, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4876 in the wild and no public exploit code.\n\nAffected product: Kaltura mwEmbed. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4876/ (Markdown: https://insights.sbomify.com/CVE-2022-4876/index.md)","id":"CVE-2022-4876","markdown":"https://insights.sbomify.com/CVE-2022-4876/index.md","name":"CVE-2022-4876","record":{"aliases":["GHSA-6m24-8j7f-j628"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Kaltura mwEmbed","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via the HTTP_X_FORWARDED_HOST header in Kaltura mwEmbed, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"mwembed","vendor":"kaltura"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Kaltura mwEmbed up to 2.96.rc1 and classified as problematic. This issue affects some unknown processing of the file includes/DefaultSettings.php. The manipulation of the argument HTTP_X_FORWARDED_HOST leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.96.rc2 is able to address this issue. The patch is named 13b8812ebc8c9fa034eed91ab35ba8423a528c0b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217427.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Kaltura mwEmbed DefaultSettings.php cross site scripting","id":"CVE-2022-4876","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2022"},"n_packages":0,"n_references":5,"next":{"headline":"snoyberg keter Proxy.hs cross site scripting","id":"CVE-2022-4877"},"packages":[],"prev":{"headline":"fossology cross site scripting","id":"CVE-2022-4875"},"products":["mwEmbed"],"published":"2023-01-04","related":[{"cvss_score":2.6,"headline":"kaltura mwEmbed Share Plugin share.js cross site scripting","id":"CVE-2022-4882","kev_date_added":null,"published":"2023-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-28","vendors":["Kaltura"]},"summary":"Remote attackers can execute arbitrary scripts via the HTTP_X_FORWARDED_HOST header in Kaltura mwEmbed, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2022-4876/"}