# CVE-2022-4876: Kaltura mwEmbed DefaultSettings.php cross site scripting

> Remote attackers can execute arbitrary scripts via the HTTP_X_FORWARDED_HOST header in Kaltura mwEmbed, requiring an upgrade to mitigate.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Jan 2023
- **Updated:** 28 May 2025
- **Also known as:** GHSA-6m24-8j7f-j628

## What is CVE-2022-4876?

CVE-2022-4876 is a low-severity cross-site scripting vulnerability in Kaltura mwEmbed, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Kaltura mwEmbed up to 2.96.rc1 and classified as problematic. This issue affects some unknown processing of the file includes/DefaultSettings.php. The manipulation of the argument HTTP_X_FORWARDED_HOST leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.96.rc2 is able to address this issue. The patch is named 13b8812ebc8c9fa034eed91ab35ba8423a528c0b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217427.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-4876?

It affects 1 product.


Products: Kaltura Mwembed.

## How do I fix CVE-2022-4876?

No fix has been published for CVE-2022-4876 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4876 being exploited?

There is no known exploitation of CVE-2022-4876 in the wild and no public exploit code.

## Other vulnerabilities in Kaltura mwEmbed

- [CVE-2022-4882](https://insights.sbomify.com/CVE-2022-4882/): kaltura mwEmbed Share Plugin share.js cross site scripting (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4876 and fix it if it is affected.

What it is: CVE-2022-4876 is a low-severity cross-site scripting vulnerability in Kaltura mwEmbed, published on 4 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4876 in the wild and no public exploit code.

Affected product: Kaltura mwEmbed. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4876/ (Markdown: https://insights.sbomify.com/CVE-2022-4876/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4876
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4876
- OSV: https://osv.dev/vulnerability/CVE-2022-4876

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4876/
Summaries are generated and may contain mistakes; the official description above is the record.
