{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4877 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-4877 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-4877 is a low-severity vulnerability in snoyberg keter, published on 5 Jan 2023."},"fix_prompt":"Check this codebase for CVE-2022-4877 and fix it if it is affected.\n\nWhat it is: CVE-2022-4877 is a low-severity vulnerability in snoyberg keter, published on 5 Jan 2023. \nExploitation: There is no known exploitation of CVE-2022-4877 in the wild and no public exploit code.\n\nAffected product: snoyberg keter. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4877/ (Markdown: https://insights.sbomify.com/CVE-2022-4877/index.md)","id":"CVE-2022-4877","markdown":"https://insights.sbomify.com/CVE-2022-4877/index.md","name":"CVE-2022-4877","record":{"aliases":["GHSA-8mwx-jcg2-3xqc"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"keter","vendor":"keter_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in snoyberg keter up to 1.8.1 and classified as problematic. This vulnerability affects unknown code of the file Keter/Proxy.hs. The manipulation of the argument host leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.8.2 is able to address this issue. The name of the patch is d41f3697926b231782a3ad8050f5af1ce5cc40b7. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217444.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"snoyberg keter Proxy.hs cross site scripting","id":"CVE-2022-4877","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2022"},"n_packages":0,"n_references":5,"next":{"headline":"JATOS ZIP ZipUtil.java ZipUtil path traversal","id":"CVE-2022-4878"},"packages":[],"prev":{"headline":"Kaltura mwEmbed DefaultSettings.php cross site scripting","id":"CVE-2022-4876"},"products":["keter"],"published":"2023-01-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["snoyberg"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-4877/"}