# CVE-2022-4877: snoyberg keter Proxy.hs cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 5 Jan 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8mwx-jcg2-3xqc

## What is CVE-2022-4877?

CVE-2022-4877 is a low-severity vulnerability in snoyberg keter, published on 5 Jan 2023. 

### Official description

A vulnerability has been found in snoyberg keter up to 1.8.1 and classified as problematic. This vulnerability affects unknown code of the file Keter/Proxy.hs. The manipulation of the argument host leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.8.2 is able to address this issue. The name of the patch is d41f3697926b231782a3ad8050f5af1ce5cc40b7. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217444.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-4877?

It affects 1 product.


Products: Keter Project Keter.

## How do I fix CVE-2022-4877?

No fix has been published for CVE-2022-4877 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4877 being exploited?

There is no known exploitation of CVE-2022-4877 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4877 and fix it if it is affected.

What it is: CVE-2022-4877 is a low-severity vulnerability in snoyberg keter, published on 5 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2022-4877 in the wild and no public exploit code.

Affected product: snoyberg keter. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4877/ (Markdown: https://insights.sbomify.com/CVE-2022-4877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4877
- OSV: https://osv.dev/vulnerability/CVE-2022-4877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4877/
Summaries are generated and may contain mistakes; the official description above is the record.
