# CVE-2022-4882: kaltura mwEmbed Share Plugin share.js cross site scripting

> Remote attackers can execute arbitrary scripts via the share.js component in Kaltura mwEmbed, requiring user interaction.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 9 Jan 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p7m9-v9m4-xjr9

## What is CVE-2022-4882?

CVE-2022-4882 is a low-severity cross-site scripting vulnerability in kaltura mwEmbed, published on 9 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in kaltura mwEmbed up to 2.91. It has been rated as problematic. Affected by this issue is some unknown functionality of the file modules/KalturaSupport/components/share/share.js of the component Share Plugin. The manipulation of the argument res leads to cross site scripting. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.92.rc1 is able to address this issue. The name of the patch is 4f11b6f6610acd6d89de5f8be47cf7c610643845. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217664.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-4882?

It affects 1 product.


Products: Kaltura Mwembed.

## How do I fix CVE-2022-4882?

No fix has been published for CVE-2022-4882 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4882 being exploited?

There is no known exploitation of CVE-2022-4882 in the wild and no public exploit code.

## Other vulnerabilities in kaltura mwEmbed

- [CVE-2022-4876](https://insights.sbomify.com/CVE-2022-4876/): Kaltura mwEmbed DefaultSettings.php cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4882 and fix it if it is affected.

What it is: CVE-2022-4882 is a low-severity cross-site scripting vulnerability in kaltura mwEmbed, published on 9 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4882 in the wild and no public exploit code.

Affected product: kaltura mwEmbed. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4882/ (Markdown: https://insights.sbomify.com/CVE-2022-4882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4882
- OSV: https://osv.dev/vulnerability/CVE-2022-4882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4882/
Summaries are generated and may contain mistakes; the official description above is the record.
