{"answers":{"affected":"3 open source packages ship an affected version, including jefferson. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4885 in the wild and no public exploit code.","fix":"Upgrade jefferson to 0.4 or later.","what":"CVE-2022-4885 is a medium-severity path traversal vulnerability in sviehb jefferson, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4885 and fix it if it is affected.\n\nWhat it is: CVE-2022-4885 is a medium-severity path traversal vulnerability in sviehb jefferson, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4885 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jefferson (PyPI): affected all versions; fixed in 0.4\n- jefferson (PyPI): affected all versions; fixed in 0.4\n- jefferson (PyPI): affected all versions; fixed in 0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4885/ (Markdown: https://insights.sbomify.com/CVE-2022-4885/index.md)","id":"CVE-2022-4885","markdown":"https://insights.sbomify.com/CVE-2022-4885/index.md","name":"CVE-2022-4885","record":{"aliases":["GHSA-7jrw-p8jc-v6qw","PYSEC-2026-826"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python jefferson library","requires_auth":"none","summary":"A remote attacker can exploit a path traversal vulnerability in the jefferson library to read arbitrary files, requiring high complexity and permissions.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"jefferson","vendor":"jefferson_project"}],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability has been found in sviehb jefferson up to 0.3 and classified as critical. This vulnerability affects unknown code of the file src/scripts/jefferson. The manipulation leads to path traversal. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.4 is able to address this issue. The name of the patch is 53b3f2fc34af0bb32afbcee29d18213e61471d87. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218020.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"sviehb jefferson path traversal","id":"CVE-2022-4885","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":3,"n_references":5,"next":{"headline":"Ingress-nginx `path` sanitization can be bypassed with `log_format` directive","id":"CVE-2022-4886"},"packages":[{"ecosystem":"PyPI","fixed":["0.4"],"introduced":["0"],"last_affected":[],"package":"jefferson","purl":null,"source":"GHSA-7jrw-p8jc-v6qw"},{"ecosystem":"PyPI","fixed":["0.4"],"introduced":["0"],"last_affected":[],"package":"jefferson","purl":"pkg:pypi/jefferson","source":"GHSA-7jrw-p8jc-v6qw"},{"ecosystem":"PyPI","fixed":["0.4"],"introduced":["0"],"last_affected":[],"package":"jefferson","purl":"pkg:pypi/jefferson","source":"PYSEC-2026-826"}],"prev":{"headline":"Path-Traversal in MKP storing","id":"CVE-2022-4884"},"products":["jefferson"],"published":"2023-01-11","related":[{"cvss_score":5.5,"headline":"Path traversal in jefferson","id":"CVE-2023-0592","kev_date_added":null,"published":"2023-01-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["sviehb"]},"summary":"A remote attacker can exploit a path traversal vulnerability in the jefferson library to read arbitrary files, requiring high complexity and permissions.","url":"https://insights.sbomify.com/CVE-2022-4885/"}