{"answers":{"affected":"2 open source packages ship an affected version, including sisimai. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4891 in the wild and no public exploit code.","fix":"Upgrade sisimai to 4.25.14p12 or later.","what":"CVE-2022-4891 is a low-severity denial of service vulnerability in Sisimai, published on 17 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-4891 and fix it if it is affected.\n\nWhat it is: CVE-2022-4891 is a low-severity denial of service vulnerability in Sisimai, published on 17 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-4891 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sisimai (RubyGems): affected all versions; fixed in 4.25.14p12\n- sisimai (RubyGems): affected all versions; fixed in 4.25.14p12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4891/ (Markdown: https://insights.sbomify.com/CVE-2022-4891/index.md)","id":"CVE-2022-4891","markdown":"https://insights.sbomify.com/CVE-2022-4891/index.md","name":"CVE-2022-4891","record":{"aliases":["GHSA-vm74-j4wq-82xj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby email parser","requires_auth":"low_privilege","summary":"An attacker can cause a denial of service in the Sisimai Ruby library by triggering inefficient regular expression complexity in the to_plain function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"sisimai","vendor":"libsisimai"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A vulnerability has been found in Sisimai up to 4.25.14p11 and classified as problematic. This vulnerability affects the function to_plain of the file lib/sisimai/string.rb. The manipulation leads to inefficient regular expression complexity. The exploit has been disclosed to the public and may be used. Upgrading to version 4.25.14p12 is able to address this issue. The name of the patch is 51fe2e6521c9c02b421b383943dc9e4bbbe65d4e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218452.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sisimai string.rb to_plain redos","id":"CVE-2022-4891","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":6,"next":{"headline":"MyCMS Visitors Module view.php build_view cross site scripting","id":"CVE-2022-4892"},"packages":[{"ecosystem":"RubyGems","fixed":["4.25.14p12"],"introduced":["0"],"last_affected":[],"package":"sisimai","purl":null,"source":"GHSA-vm74-j4wq-82xj"},{"ecosystem":"RubyGems","fixed":["4.25.14p12"],"introduced":["0"],"last_affected":[],"package":"sisimai","purl":"pkg:gem/sisimai","source":"GHSA-vm74-j4wq-82xj"}],"prev":{"headline":"abhilash1985 PredictApp Cookie new_framework_defaults_7_0.rb deserialization","id":"CVE-2022-4890"},"products":["Sisimai"],"published":"2023-01-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in the Sisimai Ruby library by triggering inefficient regular expression complexity in the to_plain function.","url":"https://insights.sbomify.com/CVE-2022-4891/"}