# CVE-2022-4891: Sisimai string.rb to_plain redos

> An attacker can cause a denial of service in the Sisimai Ruby library by triggering inefficient regular expression complexity in the to_plain function.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vm74-j4wq-82xj

## What is CVE-2022-4891?

CVE-2022-4891 is a low-severity denial of service vulnerability in Sisimai, published on 17 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been found in Sisimai up to 4.25.14p11 and classified as problematic. This vulnerability affects the function to_plain of the file lib/sisimai/string.rb. The manipulation leads to inefficient regular expression complexity. The exploit has been disclosed to the public and may be used. Upgrading to version 4.25.14p12 is able to address this issue. The name of the patch is 51fe2e6521c9c02b421b383943dc9e4bbbe65d4e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218452.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-4891?

2 open source packages ship an affected version, including sisimai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sisimai` | RubyGems | All versions | 4.25.14p12 |
| `sisimai` | RubyGems | All versions | 4.25.14p12 |

Products: Libsisimai Sisimai.

## How do I fix CVE-2022-4891?

Upgrade sisimai to 4.25.14p12 or later.

## Is CVE-2022-4891 being exploited?

There is no known exploitation of CVE-2022-4891 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4891 and fix it if it is affected.

What it is: CVE-2022-4891 is a low-severity denial of service vulnerability in Sisimai, published on 17 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4891 in the wild and no public exploit code.

Affected packages and fixed versions:
- sisimai (RubyGems): affected all versions; fixed in 4.25.14p12
- sisimai (RubyGems): affected all versions; fixed in 4.25.14p12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4891/ (Markdown: https://insights.sbomify.com/CVE-2022-4891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4891
- OSV: https://osv.dev/vulnerability/CVE-2022-4891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4891/
Summaries are generated and may contain mistakes; the official description above is the record.
