# CVE-2022-4900: Potential buffer overflow in php_cli_server_startup_workers

> Setting a large PHP_CLI_SERVER_WORKERS value causes a heap buffer overflow in the PHP CLI server, potentially allowing code execution or denial of service.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2023
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-libphp-2022-4900, BIT-php-2022-4900, BIT-php-min-2022-4900, DEBIAN-CVE-2022-4900, GHSA-95cc-jq89-8hvw, SUSE-SU-2023:1583-1, SUSE-SU-2023:1846-1, SUSE-SU-2023:1847-1, UBUNTU-CVE-2022-4900

## What is CVE-2022-4900?

CVE-2022-4900 is a medium-severity memory corruption vulnerability in Php Php, published on 2 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in PHP where setting the environment variable PHP_CLI_SERVER_WORKERS to a large value leads to a heap buffer overflow.

Weakness: CWE-787 (Out-of-bounds Write), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2022-4900?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.4.0 | 8.0.22 |
| `php` | Bitnami | From 7.4.0 | 8.0.22 |
| `php-min` | Bitnami | From 7.4.0 | 8.0.22 |
| `apache2-mod_php7` | SUSE:Linux Enterprise Module for Legacy 15 SP4 | All versions | 7.4.33-150400.4.22.1 |
| `php7` | SUSE:Linux Enterprise Module for Legacy 15 SP4 | All versions | 7.4.33-150400.4.22.1 |
| `php7-fastcgi` | SUSE:Linux Enterprise Module for Legacy 15 SP4 | All versions | 7.4.33-150400.4.22.1 |
| `php7-fpm` | SUSE:Linux Enterprise Module for Legacy 15 SP4 | All versions | 7.4.33-150400.4.22.1 |
| `php7-embed` | SUSE:Linux Enterprise Module for Package Hub 15 SP4 | All versions | 7.4.33-150400.4.22.1 |
| `php74` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.4.33-1.56.1 |
| `php74` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.4.33-1.56.1 |
| `apache2-mod_php7` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.22.1 |
| `php7` | openSUSE:Leap 15.4 | All versions | 7.4.33-150200.3.54.1 |
| `php7` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.22.1 |
| `php7-embed` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.22.1 |
| `php7-fastcgi` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.22.1 |
| `php7-fpm` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.22.1 |
| `php7-test` | openSUSE:Leap 15.4 | All versions | 7.4.33-150400.4.22.2 |

Products: Php Php, Redhat Enterprise Linux, Redhat Software Collections.

## How do I fix CVE-2022-4900?

Upgrade libphp to 8.0.22 or later.

## Is CVE-2022-4900 being exploited?

There is no known exploitation of CVE-2022-4900 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4900 and fix it if it is affected.

What it is: CVE-2022-4900 is a medium-severity memory corruption vulnerability in Php Php, published on 2 Nov 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4900 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.4.0; fixed in 8.0.22
- php (Bitnami): affected from 7.4.0; fixed in 8.0.22
- php-min (Bitnami): affected from 7.4.0; fixed in 8.0.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4900/ (Markdown: https://insights.sbomify.com/CVE-2022-4900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4900
- OSV: https://osv.dev/vulnerability/CVE-2022-4900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4900/
Summaries are generated and may contain mistakes; the official description above is the record.
