# CVE-2022-4903: CodenameOne implicit intent for sensitive communication


- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Feb 2023
- **Updated:** 24 Mar 2025
- **Also known as:** GHSA-p6xq-9h8r-v544

## What is CVE-2022-4903?

CVE-2022-4903 is a medium-severity vulnerability in CodenameOne, published on 10 Feb 2023. 

### Official description

A vulnerability was found in CodenameOne 7.0.70. It has been classified as problematic. Affected is an unknown function. The manipulation leads to use of implicit intent for sensitive communication. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 7.0.71 is able to address this issue. The patch is identified as dad49c9ef26a598619fc48d2697151a02987d478. It is recommended to upgrade the affected component. VDB-220470 is the identifier assigned to this vulnerability.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-927 (Use of Implicit Intent for Sensitive Communication)

## Which versions are affected by CVE-2022-4903?

2 open source packages ship an affected version, including com.codenameone:codenameone-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.codenameone:codenameone-core` | Maven | All versions | 7.0.71 |
| `com.codenameone:codenameone-core` | Maven | All versions | 7.0.71 |

Products: Codenameone Codename One.

## How do I fix CVE-2022-4903?

Upgrade com.codenameone:codenameone-core to 7.0.71 or later.

## Is CVE-2022-4903 being exploited?

There is no known exploitation of CVE-2022-4903 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4903 and fix it if it is affected.

What it is: CVE-2022-4903 is a medium-severity vulnerability in CodenameOne, published on 10 Feb 2023. 
Exploitation: There is no known exploitation of CVE-2022-4903 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.codenameone:codenameone-core (Maven): affected all versions; fixed in 7.0.71
- com.codenameone:codenameone-core (Maven): affected all versions; fixed in 7.0.71

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4903/ (Markdown: https://insights.sbomify.com/CVE-2022-4903/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4903
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4903
- OSV: https://osv.dev/vulnerability/CVE-2022-4903

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4903/
Summaries are generated and may contain mistakes; the official description above is the record.
