{"answers":{"affected":"2 open source packages ship an affected version, including wpcloud/wp-stateless. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4905 in the wild and no public exploit code.","fix":"Upgrade wpcloud/wp-stateless to 3.2.0 or later.","what":"CVE-2022-4905 is a low-severity cross-site scripting vulnerability in UDX Stateless Media Plugin, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4905 and fix it if it is affected.\n\nWhat it is: CVE-2022-4905 is a low-severity cross-site scripting vulnerability in UDX Stateless Media Plugin, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4905 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wpcloud/wp-stateless (Packagist): affected all versions; fixed in 3.2.0\n- wpcloud/wp-stateless (Packagist): affected all versions; fixed in 3.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4905/ (Markdown: https://insights.sbomify.com/CVE-2022-4905/index.md)","id":"CVE-2022-4905","markdown":"https://insights.sbomify.com/CVE-2022-4905/index.md","name":"CVE-2022-4905","record":{"aliases":["GHSA-9j2p-8qqf-h55c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the setup wizard interface in the UDX Stateless Media Plugin for WordPress.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"stateless_media_plugin","vendor":"udx"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in UDX Stateless Media Plugin 3.1.1 on WordPress. It has been declared as problematic. This vulnerability affects the function setup_wizard_interface of the file lib/classes/class-settings.php. The manipulation of the argument settings leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 3.2.0 is able to address this issue. The patch is identified as 6aee7ae0b0beeb2232ce6e1c82aa7e2041ae151a. It is recommended to upgrade the affected component. VDB-220750 is the identifier assigned to this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"UDX Stateless Media Plugin class-settings.php setup_wizard_interface cross site scripting","id":"CVE-2022-4905","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":5,"next":{"headline":"Memory corruption in Chrome","id":"CVE-2022-4906"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.0"],"introduced":["0"],"last_affected":[],"package":"wpcloud/wp-stateless","purl":null,"source":"GHSA-9j2p-8qqf-h55c"},{"ecosystem":"Packagist","fixed":["3.2.0"],"introduced":["0"],"last_affected":[],"package":"wpcloud/wp-stateless","purl":"pkg:composer/wpcloud/wp-stateless","source":"GHSA-9j2p-8qqf-h55c"}],"prev":{"headline":"Memory corruption in c-ares","id":"CVE-2022-4904"},"products":["Stateless Media Plugin"],"published":"2023-02-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-20","vendors":["UDX"]},"summary":"Remote attackers can inject malicious scripts via the setup wizard interface in the UDX Stateless Media Plugin for WordPress.","url":"https://insights.sbomify.com/CVE-2022-4905/"}