# CVE-2022-4905: UDX Stateless Media Plugin class-settings.php setup_wizard_interface cross site scripting

> Remote attackers can inject malicious scripts via the setup wizard interface in the UDX Stateless Media Plugin for WordPress.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Feb 2023
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-9j2p-8qqf-h55c

## What is CVE-2022-4905?

CVE-2022-4905 is a low-severity cross-site scripting vulnerability in UDX Stateless Media Plugin, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in UDX Stateless Media Plugin 3.1.1 on WordPress. It has been declared as problematic. This vulnerability affects the function setup_wizard_interface of the file lib/classes/class-settings.php. The manipulation of the argument settings leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 3.2.0 is able to address this issue. The patch is identified as 6aee7ae0b0beeb2232ce6e1c82aa7e2041ae151a. It is recommended to upgrade the affected component. VDB-220750 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-4905?

2 open source packages ship an affected version, including wpcloud/wp-stateless. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wpcloud/wp-stateless` | Packagist | All versions | 3.2.0 |
| `wpcloud/wp-stateless` | Packagist | All versions | 3.2.0 |

Products: Udx Stateless Media Plugin.

## How do I fix CVE-2022-4905?

Upgrade wpcloud/wp-stateless to 3.2.0 or later.

## Is CVE-2022-4905 being exploited?

There is no known exploitation of CVE-2022-4905 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4905 and fix it if it is affected.

What it is: CVE-2022-4905 is a low-severity cross-site scripting vulnerability in UDX Stateless Media Plugin, published on 13 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4905 in the wild and no public exploit code.

Affected packages and fixed versions:
- wpcloud/wp-stateless (Packagist): affected all versions; fixed in 3.2.0
- wpcloud/wp-stateless (Packagist): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4905/ (Markdown: https://insights.sbomify.com/CVE-2022-4905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4905
- OSV: https://osv.dev/vulnerability/CVE-2022-4905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4905/
Summaries are generated and may contain mistakes; the official description above is the record.
