CVE-2022-4928 icplayer presenter.js AddonText_Selection_create cross site scripting

Low 3.5 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2022-4928?

CVE-2022-4928 is a low-severity vulnerability in icplayer, published on 6 Mar 2023.

Official description

A vulnerability was found in icplayer up to 0.819. It has been declared as problematic. Affected by this vulnerability is the function AddonText_Selection_create of the file addons/Text_Selection/src/presenter.js. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.820 is able to address this issue. The identifier of the patch is 2223628e6db1df73f6d633d2c0422d995990f0a3. It is recommended to upgrade the affected component. The identifier VDB-222289 was assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2022-4928?

It affects 1 product.

Products include Learnetic Icplayer.

How do I fix CVE-2022-4928?

No fix has been published for CVE-2022-4928 yet. Limit exposure of the affected software until one is available.

Is CVE-2022-4928 being exploited?

There is no known exploitation of CVE-2022-4928 in the wild and no public exploit code.

Sources

Also known as GHSA-x9q2-fff7-3xq5.

Is CVE-2022-4928 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free