# CVE-2022-4929: icplayer tts-utils.js cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 6 Mar 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8jv3-m55x-9hjx

## What is CVE-2022-4929?

CVE-2022-4929 is a low-severity vulnerability in icplayer, published on 6 Mar 2023. 

### Official description

A vulnerability was found in icplayer up to 0.818. It has been rated as problematic. Affected by this issue is some unknown functionality of the file addons/Commons/src/tts-utils.js. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.819 is able to address this issue. The patch is identified as fa785969f213c76384f1fe67d47b17d57fcc60c8. It is recommended to upgrade the affected component. VDB-222290 is the identifier assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-4929?

It affects 1 product.


Products: Learnetic Icplayer.

## How do I fix CVE-2022-4929?

No fix has been published for CVE-2022-4929 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4929 being exploited?

There is no known exploitation of CVE-2022-4929 in the wild and no public exploit code.

## Other vulnerabilities in icplayer

- [CVE-2022-4928](https://insights.sbomify.com/CVE-2022-4928/): icplayer presenter.js AddonText_Selection_create cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4929 and fix it if it is affected.

What it is: CVE-2022-4929 is a low-severity vulnerability in icplayer, published on 6 Mar 2023. 
Exploitation: There is no known exploitation of CVE-2022-4929 in the wild and no public exploit code.

Affected product: icplayer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4929/ (Markdown: https://insights.sbomify.com/CVE-2022-4929/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4929
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4929
- OSV: https://osv.dev/vulnerability/CVE-2022-4929

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4929/
Summaries are generated and may contain mistakes; the official description above is the record.
