CVE-2022-4930 nuxsmin sysPass URL cross site scripting

Low 3.5 Published Updated

Remote attackers can execute arbitrary scripts via URL manipulation in sysPass, potentially compromising user sessions and data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-4930?

CVE-2022-4930 is a low-severity cross-site scripting vulnerability in nuxsmin sysPass, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic was found in nuxsmin sysPass up to 3.2.4. Affected by this vulnerability is an unknown functionality of the component URL Handler. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.2.5 is able to address this issue. The patch is named 4da4d031732ecca67519851fd0c34597dbb8ee55. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222319.

Weakness: CWE-79

Which versions are affected by CVE-2022-4930?

It affects 1 product.

Products include Syspass Syspass.

How do I fix CVE-2022-4930?

No fix has been published for CVE-2022-4930 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-4930 being exploited?

There is no known exploitation of CVE-2022-4930 in the wild and no public exploit code.

Sources

Also known as GHSA-jw86-7fhw-3vc7.

Is CVE-2022-4930 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free