{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4930 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-4930 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-4930 is a low-severity cross-site scripting vulnerability in nuxsmin sysPass, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4930 and fix it if it is affected.\n\nWhat it is: CVE-2022-4930 is a low-severity cross-site scripting vulnerability in nuxsmin sysPass, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4930 in the wild and no public exploit code.\n\nAffected product: nuxsmin sysPass. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4930/ (Markdown: https://insights.sbomify.com/CVE-2022-4930/index.md)","id":"CVE-2022-4930","markdown":"https://insights.sbomify.com/CVE-2022-4930/index.md","name":"CVE-2022-4930","record":{"aliases":["GHSA-jw86-7fhw-3vc7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"sysPass password manager","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via URL manipulation in sysPass, potentially compromising user sessions and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"syspass","vendor":"syspass"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability classified as problematic was found in nuxsmin sysPass up to 3.2.4. Affected by this vulnerability is an unknown functionality of the component URL Handler. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.2.5 is able to address this issue. The patch is named 4da4d031732ecca67519851fd0c34597dbb8ee55. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222319.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"nuxsmin sysPass URL cross site scripting","id":"CVE-2022-4930","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2022"},"n_packages":0,"n_references":5,"next":{"headline":"Missing authorization in BackUpWordPress","id":"CVE-2022-4931"},"packages":[],"prev":{"headline":"icplayer tts-utils.js cross site scripting","id":"CVE-2022-4929"},"products":["sysPass"],"published":"2023-03-06","related":[{"cvss_score":8.1,"headline":"Cross-site scripting in n/a","id":"CVE-2025-25477","kev_date_added":null,"published":"2025-02-27"},{"cvss_score":7.5,"headline":"Weak cryptography in n/a","id":"CVE-2017-5999","kev_date_added":null,"published":"2017-03-06"},{"cvss_score":6.5,"headline":"Path traversal in n/a","id":"CVE-2025-25478","kev_date_added":null,"published":"2025-02-28"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2024-42904","kev_date_added":null,"published":"2024-09-03"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2017-9306","kev_date_added":null,"published":"2017-05-31"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2025-25476","kev_date_added":null,"published":"2025-02-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-05","vendors":["nuxsmin"]},"summary":"Remote attackers can execute arbitrary scripts via URL manipulation in sysPass, potentially compromising user sessions and data.","url":"https://insights.sbomify.com/CVE-2022-4930/"}