# CVE-2022-4933: ATM Consulting dolibarr_module_quicksupplierprice interface.php upatePrice sql injection

> Remote attackers can exploit SQL injection in the Quick Supplier Price module to read or modify database contents.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Mar 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-q456-xw98-hv8x

## What is CVE-2022-4933?

CVE-2022-4933 is a medium-severity SQL injection vulnerability in ATM Consulting dolibarr_module_quicksupplierprice, published on 20 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, has been found in ATM Consulting dolibarr_module_quicksupplierprice up to 1.1.6. Affected by this issue is the function upatePrice of the file script/interface.php. The manipulation leads to sql injection. The attack may be launched remotely. Upgrading to version 1.1.7 is able to address this issue. The patch is identified as ccad1e4282b0e393a32fcc852e82ec0e0af5446f. It is recommended to upgrade the affected component. VDB-223382 is the identifier assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-4933?

It affects 1 product.


Products: Atm-Consulting Dolibarr Module Quicksupplierprice.

## How do I fix CVE-2022-4933?

No fix has been published for CVE-2022-4933 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4933 being exploited?

There is no known exploitation of CVE-2022-4933 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4933 and fix it if it is affected.

What it is: CVE-2022-4933 is a medium-severity SQL injection vulnerability in ATM Consulting dolibarr_module_quicksupplierprice, published on 20 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4933 in the wild and no public exploit code.

Affected product: ATM Consulting dolibarr_module_quicksupplierprice. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4933/ (Markdown: https://insights.sbomify.com/CVE-2022-4933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4933
- OSV: https://osv.dev/vulnerability/CVE-2022-4933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4933/
Summaries are generated and may contain mistakes; the official description above is the record.
