# CVE-2022-4944: kalcaddle KodExplorer cross-site request forgery


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 22 Apr 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-ph4w-h44m-m735

## What is CVE-2022-4944?

CVE-2022-4944 is a medium-severity vulnerability in kalcaddle KodExplorer, published on 22 Apr 2023. 

### Official description

A vulnerability, which was classified as problematic, has been found in kalcaddle KodExplorer up to 4.49. Affected by this issue is some unknown functionality. The manipulation leads to cross-site request forgery. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.50 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-227000.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-4944?

It affects 1 product.


Products: Kodcloud Kodexplorer.

## How do I fix CVE-2022-4944?

No fix has been published for CVE-2022-4944 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4944 being exploited?

There is no known exploitation of CVE-2022-4944 in the wild and no public exploit code.

Public exploit code:

- 「💥」CVE-2022-4944: KodExplorer <= 4.49 - CSRF to Arbitrary File Upload (github_poc): https://github.com/brosck/CVE-2022-4944
- KodExplorer 4.49 - CSRF to Arbitrary File Upload (exploitdb)

## Other vulnerabilities in kalcaddle KodExplorer

- [CVE-2022-46154](https://insights.sbomify.com/CVE-2022-46154/): Arbitrary file access in KodExplorer (high 8.6)
- [CVE-2023-6850](https://insights.sbomify.com/CVE-2023-6850/): kalcaddle KodExplorer API Endpoint unrestricted upload (medium 6.3)
- [CVE-2023-6851](https://insights.sbomify.com/CVE-2023-6851/): kalcaddle KodExplorer ZIP Archive app.php unzipList code injection (medium 6.3)
- [CVE-2023-6852](https://insights.sbomify.com/CVE-2023-6852/): kalcaddle KodExplorer app.php server-side request forgery (medium 6.3)
- [CVE-2023-6853](https://insights.sbomify.com/CVE-2023-6853/): kalcaddle KodExplorer app.php index server-side request forgery (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4944 and fix it if it is affected.

What it is: CVE-2022-4944 is a medium-severity vulnerability in kalcaddle KodExplorer, published on 22 Apr 2023. 
Exploitation: There is no known exploitation of CVE-2022-4944 in the wild and no public exploit code.

Affected product: kalcaddle KodExplorer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4944/ (Markdown: https://insights.sbomify.com/CVE-2022-4944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4944
- OSV: https://osv.dev/vulnerability/CVE-2022-4944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4944/
Summaries are generated and may contain mistakes; the official description above is the record.
