# CVE-2022-4952: Denial of service in csharp-language-server-protocol

> Attackers can cause resource consumption in OmniSharp csharp-language-server-protocol via the JSON Serializer, leading to denial of service.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Jul 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-g656-2879-jqrc

## What is CVE-2022-4952?

CVE-2022-4952 is a low-severity denial of service vulnerability in OmniSharp csharp-language-server-protocol, published on 17 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been found in OmniSharp csharp-language-server-protocol up to 0.19.6 and classified as problematic. This vulnerability affects the function CreateSerializerSettings of the file src/JsonRpc/Serialization/SerializerBase.cs of the component JSON Serializer. The manipulation leads to resource consumption. Upgrading to version 0.19.7 is able to address this issue. The patch is identified as 7fd2219f194a9ef2a8901bb131c5fa12272305ce. It is recommended to upgrade the affected component. VDB-234238 is the identifier assigned to this vulnerability.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-4952?

It affects 1 product.


Products: Dotnetfoundation C\# Language Server Protocol.

## How do I fix CVE-2022-4952?

No fix has been published for CVE-2022-4952 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4952 being exploited?

There is no known exploitation of CVE-2022-4952 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4952 and fix it if it is affected.

What it is: CVE-2022-4952 is a low-severity denial of service vulnerability in OmniSharp csharp-language-server-protocol, published on 17 Jul 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4952 in the wild and no public exploit code.

Affected product: OmniSharp csharp-language-server-protocol. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4952/ (Markdown: https://insights.sbomify.com/CVE-2022-4952/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4952
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4952
- OSV: https://osv.dev/vulnerability/CVE-2022-4952

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4952/
Summaries are generated and may contain mistakes; the official description above is the record.
