CVE-2022-4957 librespeed speedtest stats.php cross site scripting

Low 3.5 Published Updated

Remote attackers can execute arbitrary scripts via the id parameter in stats.php, requiring an upgrade to LibreSpeed speedtest.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-4957?

CVE-2022-4957 is a low-severity cross-site scripting vulnerability in librespeed speedtest, published on 3 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in librespeed speedtest up to 5.2.4. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file results/stats.php. The manipulation of the argument id leads to cross site scripting. The attack can be launched remotely. Upgrading to version 5.2.5 is able to address this issue. The patch is named a85f2c086f3449dffa8fe2edb5e2ef3ee72dc0e9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-246643.

Weakness: CWE-79

Which versions are affected by CVE-2022-4957?

It affects 1 product.

Products include Librespeed Speedtest.

How do I fix CVE-2022-4957?

No fix has been published for CVE-2022-4957 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-4957 being exploited?

There is no known exploitation of CVE-2022-4957 in the wild and no public exploit code.

Sources

Also known as GHSA-ggm5-39hf-58qh.

Is CVE-2022-4957 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free