{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4957 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-4957 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-4957 is a low-severity cross-site scripting vulnerability in librespeed speedtest, published on 3 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4957 and fix it if it is affected.\n\nWhat it is: CVE-2022-4957 is a low-severity cross-site scripting vulnerability in librespeed speedtest, published on 3 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4957 in the wild and no public exploit code.\n\nAffected product: librespeed speedtest. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4957/ (Markdown: https://insights.sbomify.com/CVE-2022-4957/index.md)","id":"CVE-2022-4957","markdown":"https://insights.sbomify.com/CVE-2022-4957/index.md","name":"CVE-2022-4957","record":{"aliases":["GHSA-ggm5-39hf-58qh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LibreSpeed speedtest","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via the id parameter in stats.php, requiring an upgrade to LibreSpeed speedtest.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"speedtest","vendor":"librespeed"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in librespeed speedtest up to 5.2.4. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file results/stats.php. The manipulation of the argument id leads to cross site scripting. The attack can be launched remotely. Upgrading to version 5.2.5 is able to address this issue. The patch is named a85f2c086f3449dffa8fe2edb5e2ef3ee72dc0e9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-246643.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"librespeed speedtest stats.php cross site scripting","id":"CVE-2022-4957","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2022"},"n_packages":0,"n_references":4,"next":{"headline":"qkmc-rk redbbs Post cross site scripting","id":"CVE-2022-4958"},"packages":[],"prev":{"headline":"Caphyon Advanced Installer WinSxS DLL uncontrolled search path","id":"CVE-2022-4956"},"products":["speedtest"],"published":"2023-12-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-03","vendors":["librespeed"]},"summary":"Remote attackers can execute arbitrary scripts via the id parameter in stats.php, requiring an upgrade to LibreSpeed speedtest.","url":"https://insights.sbomify.com/CVE-2022-4957/"}