# CVE-2022-4957: librespeed speedtest stats.php cross site scripting

> Remote attackers can execute arbitrary scripts via the id parameter in stats.php, requiring an upgrade to LibreSpeed speedtest.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 3 Dec 2023
- **Updated:** 3 Jun 2025
- **Also known as:** GHSA-ggm5-39hf-58qh

## What is CVE-2022-4957?

CVE-2022-4957 is a low-severity cross-site scripting vulnerability in librespeed speedtest, published on 3 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in librespeed speedtest up to 5.2.4. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file results/stats.php. The manipulation of the argument id leads to cross site scripting. The attack can be launched remotely. Upgrading to version 5.2.5 is able to address this issue. The patch is named a85f2c086f3449dffa8fe2edb5e2ef3ee72dc0e9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-246643.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-4957?

It affects 1 product.


Products: Librespeed Speedtest.

## How do I fix CVE-2022-4957?

No fix has been published for CVE-2022-4957 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4957 being exploited?

There is no known exploitation of CVE-2022-4957 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4957 and fix it if it is affected.

What it is: CVE-2022-4957 is a low-severity cross-site scripting vulnerability in librespeed speedtest, published on 3 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4957 in the wild and no public exploit code.

Affected product: librespeed speedtest. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4957/ (Markdown: https://insights.sbomify.com/CVE-2022-4957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4957
- OSV: https://osv.dev/vulnerability/CVE-2022-4957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4957/
Summaries are generated and may contain mistakes; the official description above is the record.
