{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2022-4966 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-4966 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-4966 is a low-severity cross-site scripting vulnerability in sequentech admin-console, published on 1 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4966 and fix it if it is affected.\n\nWhat it is: CVE-2022-4966 is a low-severity cross-site scripting vulnerability in sequentech admin-console, published on 1 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4966 in the wild and no public exploit code.\n\nAffected product: sequentech admin-console. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4966/ (Markdown: https://insights.sbomify.com/CVE-2022-4966/index.md)","id":"CVE-2022-4966","markdown":"https://insights.sbomify.com/CVE-2022-4966/index.md","name":"CVE-2022-4966","record":{"aliases":["GHSA-rc2r-qm5x-rv9w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"sequentech admin-console","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts into the Election Description field, potentially compromising user sessions or executing code.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in sequentech admin-console up to 6.1.7 and classified as problematic. Affected by this issue is some unknown functionality of the component Election Description Handler. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 7.0.0-beta.1 is able to address this issue. The patch is identified as 0043a6b1e6e0f5abc9557e73f9ffc524fc5d609d. It is recommended to upgrade the affected component. VDB-258782 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"sequentech admin-console Election Description cross site scripting","id":"CVE-2022-4966","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2022"},"n_packages":0,"n_references":6,"next":{"headline":"Auth bypass in strongSwan","id":"CVE-2022-4967"},"packages":[],"prev":{"headline":"Invitation Code Content Restriction Plugin from CreativeMinds \u003c= 1.5.4 - Reflected Cross-Site Scripting","id":"CVE-2022-4965"},"products":["admin-console"],"published":"2024-04-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-19","vendors":["sequentech"]},"summary":"Remote attackers can inject malicious scripts into the Election Description field, potentially compromising user sessions or executing code.","url":"https://insights.sbomify.com/CVE-2022-4966/"}