{"answers":{"affected":"3 open source packages ship an affected version, including rockhopper.","exploited":"There is no known exploitation of CVE-2022-4969 in the wild and no public exploit code.","fix":"Upgrade rockhopper to 0.2.0 or later.","what":"CVE-2022-4969 is a medium-severity memory corruption vulnerability in bwoodsend rockhopper, published on 27 May 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-4969 and fix it if it is affected.\n\nWhat it is: CVE-2022-4969 is a medium-severity memory corruption vulnerability in bwoodsend rockhopper, published on 27 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-4969 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rockhopper (PyPI): affected all versions; fixed in 0.2.0\n- rockhopper (PyPI): affected all versions; fixed in 0.2.0\n- rockhopper (PyPI): affected all versions; fixed in 0.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4969/ (Markdown: https://insights.sbomify.com/CVE-2022-4969/index.md)","id":"CVE-2022-4969","markdown":"https://insights.sbomify.com/CVE-2022-4969/index.md","name":"CVE-2022-4969","record":{"aliases":["GHSA-4r4c-66gf-g9g5","PYSEC-2026-1875"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python binary parser library","requires_auth":"low_privilege","summary":"A buffer overflow in the rockhopper binary parser allows local attackers to execute arbitrary code or cause denial of service via crafted input.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"A vulnerability, which was classified as critical, has been found in bwoodsend rockhopper up to 0.1.2. Affected by this issue is the function count_rows of the file rockhopper/src/ragged_array.c of the component Binary Parser. The manipulation of the argument raw leads to buffer overflow. Local access is required to approach this attack. Upgrading to version 0.2.0 is able to address this issue. The name of the patch is 1a15fad5e06ae693eb9b8908363d2c8ef455104e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-266312.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"bwoodsend rockhopper Binary Parser ragged_array.c count_rows buffer overflow","id":"CVE-2022-4969","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"Sassy Social Share \u003c= 3.3.3 - Reflected Cross-Site Scripting","id":"CVE-2022-4971"},"packages":[{"ecosystem":"PyPI","fixed":["0.2.0"],"introduced":["0"],"last_affected":[],"package":"rockhopper","purl":null,"source":"GHSA-4r4c-66gf-g9g5"},{"ecosystem":"PyPI","fixed":["0.2.0"],"introduced":["0"],"last_affected":[],"package":"rockhopper","purl":"pkg:pypi/rockhopper","source":"GHSA-4r4c-66gf-g9g5"},{"ecosystem":"PyPI","fixed":["0.2.0"],"introduced":["0"],"last_affected":[],"package":"rockhopper","purl":"pkg:pypi/rockhopper","source":"PYSEC-2026-1875"}],"prev":{"headline":"Information disclosure in Netplan","id":"CVE-2022-4968"},"products":["rockhopper"],"published":"2024-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-03","vendors":["bwoodsend"]},"summary":"A buffer overflow in the rockhopper binary parser allows local attackers to execute arbitrary code or cause denial of service via crafted input.","url":"https://insights.sbomify.com/CVE-2022-4969/"}