{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4973 in the wild and no public exploit code.","fix":"Upgrade wordpress to a fixed version for your release line: 3.6.2, 3.7.39, 3.8.39 or 3.9.37.","what":"CVE-2022-4973 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 16 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-4973 and fix it if it is affected.\n\nWhat it is: CVE-2022-4973 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 16 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-4973 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 3.6.2, 3.7.39, 3.8.39, 3.9.37, 4.0.36, 4.1.36, 4.2.33, 4.3.29, 4.4.28, 4.5.27, 4.6.24, 4.7.24, 4.8.20, 4.9.21, 5.0.17, 5.1.14, 5.2.16, 5.3.13, 5.4.11, 5.5.10, 5.6.9, 5.7.7, 5.8.5, 5.9.4, 6.0.2\n- wordpress-multisite (Bitnami): affected all versions; fixed in 3.6.2, 3.7.39, 3.8.39, 3.9.37, 4.0.36, 4.1.36, 4.2.33, 4.3.29, 4.4.28, 4.5.27, 4.6.24, 4.7.24, 4.8.20, 4.9.21, 5.0.17, 5.1.14, 5.2.16, 5.3.13, 5.4.11, 5.5.10, 5.6.9, 5.7.7, 5.8.5, 5.9.4, 6.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4973/ (Markdown: https://insights.sbomify.com/CVE-2022-4973/index.md)","id":"CVE-2022-4973","markdown":"https://insights.sbomify.com/CVE-2022-4973/index.md","name":"CVE-2022-4973","record":{"aliases":["BIT-wordpress-2022-4973","BIT-wordpress-multisite-2022-4973","DEBIAN-CVE-2022-4973","GHSA-mhf3-8588-hqc6","UBUNTU-CVE-2022-4973"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress core","requires_auth":"low_privilege","summary":"Authenticated users can inject scripts into posts via the_meta function, leading to stored XSS execution on affected pages.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"WordPress Core, in versions up to 6.0.2, is vulnerable to Authenticated Stored Cross-Site Scripting that can be exploited by users with access to the WordPress post and page editor, typically consisting of Authors, Contributors, and Editors making it possible to inject arbitrary web scripts into posts and pages that execute if the the_meta(); function is called on that page.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Core \u003c 6.0.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via use of the_meta(); function","id":"CVE-2022-4973","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"wordpress:wordpress","products":["wordpress:wordpress"],"type":"xss","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Freemius SDK \u003c= 2.4.2 - Missing Authorization Checks","id":"CVE-2022-4974"},"packages":[{"ecosystem":"Bitnami","fixed":["3.6.2","3.7.39","3.8.39","3.9.37","4.0.36","4.1.36","4.2.33","4.3.29","4.4.28","4.5.27","4.6.24","4.7.24","4.8.20","4.9.21","5.0.17","5.1.14","5.2.16","5.3.13","5.4.11","5.5.10","5.6.9","5.7.7","5.8.5","5.9.4","6.0.2"],"introduced":["0","3.7.0","3.8.0","3.9.0","4.0.0","4.1.0","4.2.0","4.3.0","4.4.0","4.5.0","4.6.0","4.7.0","4.8.0","4.9.0","5.0.0","5.1.0","5.2.0","5.3.0","5.4.0","5.5.0","5.6.0","5.7.0","5.8.0","5.9.0","6.0.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2022-4973"},{"ecosystem":"Bitnami","fixed":["3.6.2","3.7.39","3.8.39","3.9.37","4.0.36","4.1.36","4.2.33","4.3.29","4.4.28","4.5.27","4.6.24","4.7.24","4.8.20","4.9.21","5.0.17","5.1.14","5.2.16","5.3.13","5.4.11","5.5.10","5.6.9","5.7.7","5.8.5","5.9.4","6.0.2"],"introduced":["0","3.7.0","3.8.0","3.9.0","4.0.0","4.1.0","4.2.0","4.3.0","4.4.0","4.5.0","4.6.0","4.7.0","4.8.0","4.9.0","5.0.0","5.1.0","5.2.0","5.3.0","5.4.0","5.5.0","5.6.0","5.7.0","5.8.0","5.9.0","6.0.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2022-4973"}],"prev":{"headline":"Download Monitor \u003c= 4.7.51 - Missing Authorization to Unauthenticated Data Export","id":"CVE-2022-4972"},"products":["WordPress"],"published":"2024-10-16","related":[{"cvss_score":9.8,"headline":"WordPress Core Interpretation Conflict","id":"CVE-2026-63030","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":8.1,"headline":"WordPress Core Remote File Inclusion","id":"CVE-2026-87902","kev_date_added":"2026-09-25","published":"2026-09-22"},{"cvss_score":5.9,"headline":"WordPress Core SQL Injection","id":"CVE-2026-60137","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2012-2399","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2012-2400","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3122","kev_date_added":null,"published":"2011-08-10"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3125","kev_date_added":null,"published":"2011-08-10"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["WordPress Foundation"]},"summary":"Authenticated users can inject scripts into posts via the_meta function, leading to stored XSS execution on affected pages.","url":"https://insights.sbomify.com/CVE-2022-4973/"}