{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri.","exploited":"There is no known exploitation of CVE-2022-50998 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.13.9 or later.","what":"CVE-2022-50998 is a vulnerability in nokogiri, published on 25 Aug 2026."},"fix_prompt":"Check this codebase for CVE-2022-50998 and fix it if it is affected.\n\nWhat it is: CVE-2022-50998 is a vulnerability in nokogiri, published on 25 Aug 2026. \nExploitation: There is no known exploitation of CVE-2022-50998 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.9\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-50998/ (Markdown: https://insights.sbomify.com/CVE-2022-50998/index.md)","id":"CVE-2022-50998","markdown":"https://insights.sbomify.com/CVE-2022-50998/index.md","name":"CVE-2022-50998","record":{"aliases":["GHSA-2qc6-mcvw-92cw","GHSA-849j-3m7w-q32f"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"This CVE ID has been rejected as a duplicate.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Update bundled libxml2 to v2.10.3 to resolve multiple CVEs","id":"CVE-2022-50998","indexable":false,"kev":null,"kind":"cve_rejected","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2022"},"n_packages":2,"n_references":0,"next":{"headline":"Integer Overflow or Wraparound in libxml2 affects Nokogiri","id":"CVE-2022-50999"},"packages":[{"ecosystem":"RubyGems","fixed":["1.13.9"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-2qc6-mcvw-92cw"},{"ecosystem":"RubyGems","fixed":["1.13.9"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-2qc6-mcvw-92cw"}],"prev":{"headline":"Weaver E-cology 8.0 / 9.0 SQL Injection via HrmCareerApplyPerView.jsp","id":"CVE-2022-50997"},"products":[],"published":"2026-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"REJECTED","updated":"2026-09-08","vendors":[]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-50998/"}