{"answers":{"affected":"2 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2022-51009 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to 4.7.2 or later.","what":"CVE-2022-51009 is a high-severity vulnerability in pmmp PocketMine-MP, published on 6 Sep 2026."},"fix_prompt":"Check this codebase for CVE-2022-51009 and fix it if it is affected.\n\nWhat it is: CVE-2022-51009 is a high-severity vulnerability in pmmp PocketMine-MP, published on 6 Sep 2026. \nExploitation: There is no known exploitation of CVE-2022-51009 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.7.2\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-51009/ (Markdown: https://insights.sbomify.com/CVE-2022-51009/index.md)","id":"CVE-2022-51009","markdown":"https://insights.sbomify.com/CVE-2022-51009/index.md","name":"CVE-2022-51009","record":{"aliases":["GHSA-8cwq-4cmf-px73","GHSA-pmcx-fxxc-37gm"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"PocketMine-MP before 4.7.2 fails to properly handle exceptions from the adhocore/json-comment library when parsing skin geometry data. Attackers can send login or skin packets with invalid geometry JSON to trigger an unhandled RuntimeException, causing server crash.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"PocketMine-MP before 4.7.2 Denial of Service via Skin Geometry","id":"CVE-2022-51009","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"PocketMine-MP before 4.4.2 Server Crash via Item ID","id":"CVE-2022-51010"},"packages":[{"ecosystem":"Packagist","fixed":["4.7.2"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-8cwq-4cmf-px73"},{"ecosystem":"Packagist","fixed":["4.7.2"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-8cwq-4cmf-px73"}],"prev":{"headline":"PocketMine-MP before 4.12.3 Denial of Service via Unauthenticated Sessions","id":"CVE-2022-51008"},"products":["PocketMine-MP"],"published":"2026-09-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-51009/"}