# CVE-2022-51009: PocketMine-MP before 4.7.2 Denial of Service via Skin Geometry


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 6 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-8cwq-4cmf-px73, GHSA-pmcx-fxxc-37gm

## What is CVE-2022-51009?

CVE-2022-51009 is a high-severity vulnerability in pmmp PocketMine-MP, published on 6 Sep 2026. 

### Official description

PocketMine-MP before 4.7.2 fails to properly handle exceptions from the adhocore/json-comment library when parsing skin geometry data. Attackers can send login or skin packets with invalid geometry JSON to trigger an unhandled RuntimeException, causing server crash.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2022-51009?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.7.2 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 4.7.2 |

## How do I fix CVE-2022-51009?

Upgrade pocketmine/pocketmine-mp to 4.7.2 or later.

## Is CVE-2022-51009 being exploited?

There is no known exploitation of CVE-2022-51009 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-51009 and fix it if it is affected.

What it is: CVE-2022-51009 is a high-severity vulnerability in pmmp PocketMine-MP, published on 6 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2022-51009 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.7.2
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-51009/ (Markdown: https://insights.sbomify.com/CVE-2022-51009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-51009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-51009
- OSV: https://osv.dev/vulnerability/CVE-2022-51009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-51009/
Summaries are generated and may contain mistakes; the official description above is the record.
