{"answers":{"affected":"2 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2022-51010 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to 4.4.2 or later.","what":"CVE-2022-51010 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-51010 and fix it if it is affected.\n\nWhat it is: CVE-2022-51010 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-51010 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0-BETA5; fixed in 4.4.2\n- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0-BETA5; fixed in 4.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-51010/ (Markdown: https://insights.sbomify.com/CVE-2022-51010/index.md)","id":"CVE-2022-51010","markdown":"https://insights.sbomify.com/CVE-2022-51010/index.md","name":"CVE-2022-51010","record":{"aliases":["GHSA-92gq-jvgx-hx4m","GHSA-fqx3-r75h-vc89"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft server software","requires_auth":"low_privilege","summary":"Attackers can crash the PocketMine-MP server by sending invalid item IDs, requiring administrators to upgrade to a patched version.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in itemstack NBT data. Attackers can send crafted item IDs outside the valid range to trigger an uncaught exception that crashes the server.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"PocketMine-MP before 4.4.2 Server Crash via Item ID","id":"CVE-2022-51010","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"PocketMine-MP before 4.2.10 Denial of Service via Chat Messages","id":"CVE-2022-51011"},"packages":[{"ecosystem":"Packagist","fixed":["4.4.2"],"introduced":["4.0.0-BETA5"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-fqx3-r75h-vc89"},{"ecosystem":"Packagist","fixed":["4.4.2"],"introduced":["4.0.0-BETA5"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-fqx3-r75h-vc89"}],"prev":{"headline":"PocketMine-MP before 4.7.2 Denial of Service via Skin Geometry","id":"CVE-2022-51009"},"products":["PocketMine-MP"],"published":"2026-09-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":"Attackers can crash the PocketMine-MP server by sending invalid item IDs, requiring administrators to upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2022-51010/"}