# CVE-2022-51010: PocketMine-MP before 4.4.2 Server Crash via Item ID

> Attackers can crash the PocketMine-MP server by sending invalid item IDs, requiring administrators to upgrade to a patched version.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-92gq-jvgx-hx4m, GHSA-fqx3-r75h-vc89

## What is CVE-2022-51010?

CVE-2022-51010 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PocketMine-MP versions before 4.4.2 fail to properly validate item IDs received from clients in itemstack NBT data. Attackers can send crafted item IDs outside the valid range to trigger an uncaught exception that crashes the server.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-51010?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | From 4.0.0-BETA5 | 4.4.2 |
| `pocketmine/pocketmine-mp` | Packagist | From 4.0.0-BETA5 | 4.4.2 |

## How do I fix CVE-2022-51010?

Upgrade pocketmine/pocketmine-mp to 4.4.2 or later.

## Is CVE-2022-51010 being exploited?

There is no known exploitation of CVE-2022-51010 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-51010 and fix it if it is affected.

What it is: CVE-2022-51010 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-51010 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0-BETA5; fixed in 4.4.2
- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0-BETA5; fixed in 4.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-51010/ (Markdown: https://insights.sbomify.com/CVE-2022-51010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-51010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-51010
- OSV: https://osv.dev/vulnerability/CVE-2022-51010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-51010/
Summaries are generated and may contain mistakes; the official description above is the record.
