{"answers":{"affected":"2 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2022-51013 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to 4.2.4 or later.","what":"CVE-2022-51013 is a high-severity vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026."},"fix_prompt":"Check this codebase for CVE-2022-51013 and fix it if it is affected.\n\nWhat it is: CVE-2022-51013 is a high-severity vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. \nExploitation: There is no known exploitation of CVE-2022-51013 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.2.4\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 4.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-51013/ (Markdown: https://insights.sbomify.com/CVE-2022-51013/index.md)","id":"CVE-2022-51013","markdown":"https://insights.sbomify.com/CVE-2022-51013/index.md","name":"CVE-2022-51013","record":{"aliases":["GHSA-46c5-pfj8-fv65","GHSA-fxmr-46xq-5m9m"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"PocketMine-MP versions before 4.2.3 fail to validate damage metadata values in tool and armor item NBT data received from clients. Attackers can send negative or out-of-range damage values in itemstack NBT to trigger unhandled exceptions in the Durable class, causing server crashes.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"PocketMine-MP before 4.2.3 Denial of Service via NBT Metadata","id":"CVE-2022-51013","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"PocketMine-MP before 4.0.7 Denial of Service via JSON Decoding","id":"CVE-2022-51014"},"packages":[{"ecosystem":"Packagist","fixed":["4.2.4"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-46c5-pfj8-fv65"},{"ecosystem":"Packagist","fixed":["4.2.4"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-46c5-pfj8-fv65"}],"prev":{"headline":"PocketMine-MP before 4.2.9 Denial of Service via NBT Deserialization","id":"CVE-2022-51012"},"products":["PocketMine-MP"],"published":"2026-09-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-51013/"}