# CVE-2022-51016: PocketMine-MP 3.x before 3.27.0 Authentication Bypass via Login Replay

> Attackers can replay captured login tokens to impersonate players and bypass authentication on PocketMine-MP servers lacking encryption.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 7 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-h79x-98r2-g6qc, GHSA-xc6f-r2f5-fwj7

## What is CVE-2022-51016?

CVE-2022-51016 is a medium-severity authentication bypass vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PocketMine-MP 3.x (before 3.27.0) does not implement Minecraft Bedrock protocol encryption, so the server cannot verify that a connecting client possesses the private key corresponding to its login token. An attacker who captures a valid login from another player's session (for example by tricking the player into connecting to an attacker-controlled server) can replay that login to impersonate the victim and pass XBOX Live authentication until the JWT token expires (typically 2-3 days). This affects servers directly reachable over the internet that are not behind a proxy with encryption enabled. Fixed in 4.0.0 and backported to 3.27.0.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2022-51016?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | From 3.0.0 | 4.0.0 |
| `pocketmine/pocketmine-mp` | Packagist | From 3.0.0 | 4.0.0 |

## How do I fix CVE-2022-51016?

Upgrade pocketmine/pocketmine-mp to 4.0.0 or later.

## Is CVE-2022-51016 being exploited?

There is no known exploitation of CVE-2022-51016 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-51016 and fix it if it is affected.

What it is: CVE-2022-51016 is a medium-severity authentication bypass vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-51016 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected from 3.0.0; fixed in 4.0.0
- pocketmine/pocketmine-mp (Packagist): affected from 3.0.0; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-51016/ (Markdown: https://insights.sbomify.com/CVE-2022-51016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-51016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-51016
- OSV: https://osv.dev/vulnerability/CVE-2022-51016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-51016/
Summaries are generated and may contain mistakes; the official description above is the record.
