CVE-2022-51017 PocketMine-MP before 3.26.5 and 4.0.5 Denial of Service via Skin Data
Attackers can crash the PocketMine-MP server by submitting oversized skin data fields that exceed NBT string limits.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2022-51017?
CVE-2022-51017 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PocketMine-MP versions before 3.26.5 and 4.0.5 fail to validate the length of skin data fields submitted by players, allowing uncapped values to exceed the 32767 byte TAG_String limit. Attackers can submit oversized skin data fields like skinID or geometryName to trigger exceptions during NBT data serialization, causing server crashes.
Weakness: CWE-20
Which versions are affected by CVE-2022-51017?
4 open source packages ship an affected version, including pocketmine/pocketmine-mp.
| Package | Affected | Fixed in |
|---|---|---|
pocketmine/pocketmine-mp Packagist | All versions | 3.26.5 |
pocketmine/pocketmine-mp Packagist | All versions | 3.26.5 |
pocketmine/pocketmine-mp Packagist | From 4.0.0 | 4.0.5 |
pocketmine/pocketmine-mp Packagist | From 4.0.0 | 4.0.5 |
How do I fix CVE-2022-51017?
Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 3.26.5 or 4.0.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-51017 being exploited?
There is no known exploitation of CVE-2022-51017 in the wild and no public exploit code.
Sources
Also known as GHSA-c6fg-99pr-25m9, GHSA-q675-2qq9-hxh3.