{"answers":{"affected":"4 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2022-51017 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 3.26.5 or 4.0.5.","what":"CVE-2022-51017 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-51017 and fix it if it is affected.\n\nWhat it is: CVE-2022-51017 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-51017 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 3.26.5\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 3.26.5\n- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0; fixed in 4.0.5\n- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0; fixed in 4.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-51017/ (Markdown: https://insights.sbomify.com/CVE-2022-51017/index.md)","id":"CVE-2022-51017","markdown":"https://insights.sbomify.com/CVE-2022-51017/index.md","name":"CVE-2022-51017","record":{"aliases":["GHSA-c6fg-99pr-25m9","GHSA-q675-2qq9-hxh3"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft server software","requires_auth":"none","summary":"Attackers can crash the PocketMine-MP server by submitting oversized skin data fields that exceed NBT string limits.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"PocketMine-MP versions before 3.26.5 and 4.0.5 fail to validate the length of skin data fields submitted by players, allowing uncapped values to exceed the 32767 byte TAG_String limit. Attackers can submit oversized skin data fields like skinID or geometryName to trigger exceptions during NBT data serialization, causing server crashes.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"PocketMine-MP before 3.26.5 and 4.0.5 Denial of Service via Skin Data","id":"CVE-2022-51017","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":4,"n_references":4,"next":{"headline":"PocketMine-MP before 3.26.5 and 4.0.5 Input Validation via Book Pages","id":"CVE-2022-51018"},"packages":[{"ecosystem":"Packagist","fixed":["3.26.5"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-c6fg-99pr-25m9"},{"ecosystem":"Packagist","fixed":["3.26.5"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-c6fg-99pr-25m9"},{"ecosystem":"Packagist","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-c6fg-99pr-25m9"},{"ecosystem":"Packagist","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-c6fg-99pr-25m9"}],"prev":{"headline":"PocketMine-MP 3.x before 3.27.0 Authentication Bypass via Login Replay","id":"CVE-2022-51016"},"products":["PocketMine-MP"],"published":"2026-09-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":"Attackers can crash the PocketMine-MP server by submitting oversized skin data fields that exceed NBT string limits.","url":"https://insights.sbomify.com/CVE-2022-51017/"}