CVE-2022-51018 PocketMine-MP before 3.26.5 and 4.0.5 Input Validation via Book Pages
Attackers can crash PocketMine-MP servers by creating oversized writable books, causing excessive bandwidth usage and server crashes.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2022-51018?
CVE-2022-51018 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
PocketMine-MP before 3.26.5 and 4.0.x before 4.0.5 does not limit book page text length, page count, or author/title length. A player who obtains a writable book can create oversized NBT ('book bombs'), causing excess bandwidth consumption and server crashes (exceeding the 1 MB chunk size limit when saving region-based worlds in PM3, or exceeding the 32 KiB TAG_String limit in PM4).
Weakness: CWE-400
Which versions are affected by CVE-2022-51018?
4 open source packages ship an affected version, including pocketmine/pocketmine-mp.
| Package | Affected | Fixed in |
|---|---|---|
pocketmine/pocketmine-mp Packagist | All versions | 3.26.5 |
pocketmine/pocketmine-mp Packagist | All versions | 3.26.5 |
pocketmine/pocketmine-mp Packagist | From 4.0.0 | 4.0.5 |
pocketmine/pocketmine-mp Packagist | From 4.0.0 | 4.0.5 |
How do I fix CVE-2022-51018?
Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 3.26.5 or 4.0.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-51018 being exploited?
There is no known exploitation of CVE-2022-51018 in the wild and no public exploit code.
Sources
Also known as GHSA-p62j-hrxm-xcxf, GHSA-q643-57w3-775x.