{"answers":{"affected":"4 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"There is no known exploitation of CVE-2022-51018 in the wild and no public exploit code.","fix":"Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 3.26.5 or 4.0.5.","what":"CVE-2022-51018 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-51018 and fix it if it is affected.\n\nWhat it is: CVE-2022-51018 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-51018 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 3.26.5\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 3.26.5\n- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0; fixed in 4.0.5\n- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0; fixed in 4.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-51018/ (Markdown: https://insights.sbomify.com/CVE-2022-51018/index.md)","id":"CVE-2022-51018","markdown":"https://insights.sbomify.com/CVE-2022-51018/index.md","name":"CVE-2022-51018","record":{"aliases":["GHSA-p62j-hrxm-xcxf","GHSA-q643-57w3-775x"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft server software","requires_auth":"low_privilege","summary":"Attackers can crash PocketMine-MP servers by creating oversized writable books, causing excessive bandwidth usage and server crashes.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"PocketMine-MP before 3.26.5 and 4.0.x before 4.0.5 does not limit book page text length, page count, or author/title length. A player who obtains a writable book can create oversized NBT ('book bombs'), causing excess bandwidth consumption and server crashes (exceeding the 1 MB chunk size limit when saving region-based worlds in PM3, or exceeding the 32 KiB TAG_String limit in PM4).","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"PocketMine-MP before 3.26.5 and 4.0.5 Input Validation via Book Pages","id":"CVE-2022-51018","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":4,"n_references":2,"next":{"headline":"Akaunting before 2.1.31 OS Command Injection via app alias","id":"CVE-2022-51019"},"packages":[{"ecosystem":"Packagist","fixed":["3.26.5"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-p62j-hrxm-xcxf"},{"ecosystem":"Packagist","fixed":["3.26.5"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-p62j-hrxm-xcxf"},{"ecosystem":"Packagist","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-p62j-hrxm-xcxf"},{"ecosystem":"Packagist","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-p62j-hrxm-xcxf"}],"prev":{"headline":"PocketMine-MP before 3.26.5 and 4.0.5 Denial of Service via Skin Data","id":"CVE-2022-51017"},"products":["PocketMine-MP"],"published":"2026-09-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":"Attackers can crash PocketMine-MP servers by creating oversized writable books, causing excessive bandwidth usage and server crashes.","url":"https://insights.sbomify.com/CVE-2022-51018/"}