# CVE-2022-51018: PocketMine-MP before 3.26.5 and 4.0.5 Input Validation via Book Pages

> Attackers can crash PocketMine-MP servers by creating oversized writable books, causing excessive bandwidth usage and server crashes.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-p62j-hrxm-xcxf, GHSA-q643-57w3-775x

## What is CVE-2022-51018?

CVE-2022-51018 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PocketMine-MP before 3.26.5 and 4.0.x before 4.0.5 does not limit book page text length, page count, or author/title length. A player who obtains a writable book can create oversized NBT ('book bombs'), causing excess bandwidth consumption and server crashes (exceeding the 1 MB chunk size limit when saving region-based worlds in PM3, or exceeding the 32 KiB TAG_String limit in PM4).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-51018?

4 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 3.26.5 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 3.26.5 |
| `pocketmine/pocketmine-mp` | Packagist | From 4.0.0 | 4.0.5 |
| `pocketmine/pocketmine-mp` | Packagist | From 4.0.0 | 4.0.5 |

## How do I fix CVE-2022-51018?

Upgrade pocketmine/pocketmine-mp to a fixed version for your release line: 3.26.5 or 4.0.5.

## Is CVE-2022-51018 being exploited?

There is no known exploitation of CVE-2022-51018 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-51018 and fix it if it is affected.

What it is: CVE-2022-51018 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-51018 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 3.26.5
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 3.26.5
- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0; fixed in 4.0.5
- pocketmine/pocketmine-mp (Packagist): affected from 4.0.0; fixed in 4.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-51018/ (Markdown: https://insights.sbomify.com/CVE-2022-51018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-51018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-51018
- OSV: https://osv.dev/vulnerability/CVE-2022-51018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-51018/
Summaries are generated and may contain mistakes; the official description above is the record.
