# CVE-2022-51026: Bytebase 0.12.0 before 1.0.1 Authentication Bypass via GitLab Self-Hosted Login


- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-5r3p-6rj5-7937, GHSA-ffpw-wpwq-rh9j

## What is CVE-2022-51026?

CVE-2022-51026 is a critical vulnerability in bytebase, published on 22 Oct 2026. 

### Official description

Bytebase 0.12.0 before 1.0.1 contains an authentication bypass vulnerability that allows unauthenticated attackers to log in as any user. The flaw stems from trusting client-supplied GitLab provider configuration in the POST /api/auth/login/GITLAB_SELF_HOST endpoint. Attackers can set instanceUrl to a server they control that returns an active user with a chosen email. Bytebase then issues session tokens for that principal, letting attackers impersonate existing users including the Owner or create new members.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2022-51026?

2 open source packages ship an affected version, including github.com/bytebase/bytebase.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/bytebase/bytebase` | Go | All versions | 1.0.1 |
| `github.com/bytebase/bytebase` | Go | All versions | 1.0.1 |

## How do I fix CVE-2022-51026?

Upgrade github.com/bytebase/bytebase to 1.0.1 or later.

## Is CVE-2022-51026 being exploited?

There is no known exploitation of CVE-2022-51026 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-51026 and fix it if it is affected.

What it is: CVE-2022-51026 is a critical vulnerability in bytebase, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2022-51026 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/bytebase/bytebase (Go): affected all versions; fixed in 1.0.1
- github.com/bytebase/bytebase (Go): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-51026/ (Markdown: https://insights.sbomify.com/CVE-2022-51026/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-51026
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-51026
- OSV: https://osv.dev/vulnerability/CVE-2022-51026

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-51026/
Summaries are generated and may contain mistakes; the official description above is the record.
