# CVE-2023-0044: Cross-site Scripting in Quarkus

> Attackers can exploit cross-site scripting via session cookies to disclose information if CSRF protection is disabled.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Feb 2023
- **Updated:** 12 Mar 2025
- **Also known as:** GHSA-c57v-hc7m-8px2

## What is CVE-2023-0044?

CVE-2023-0044 is a medium-severity cross-site scripting vulnerability in quarkus-vertx-http, published on 23 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

If the Quarkus Form Authentication session cookie Path attribute is set to `/` then a cross-site attack may be initiated which might lead to the Information Disclosure. This attack can be prevented with the Quarkus CSRF Prevention feature.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-0044?

2 open source packages ship an affected version, including io.quarkus:quarkus-vertx-http. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.quarkus:quarkus-vertx-http` | Maven | All versions | 2.13.7.Final |
| `io.quarkus:quarkus-vertx-http` | Maven | All versions | 2.13.7.Final |

Products: Quarkus Quarkus, Redhat Build of Quarkus.

## How do I fix CVE-2023-0044?

Upgrade io.quarkus:quarkus-vertx-http to 2.13.7.Final or later.

## Is CVE-2023-0044 being exploited?

There is no known exploitation of CVE-2023-0044 in the wild and no public exploit code.

## Other vulnerabilities in quarkus-vertx-http

- [CVE-2022-4116](https://insights.sbomify.com/CVE-2022-4116/): Code injection in quarkus dev ui config editor (critical 9.8)
- [CVE-2022-2466](https://insights.sbomify.com/CVE-2022-2466/): Quarkus does not terminate HTTP requests header context (critical 9.8)
- [CVE-2024-12225](https://insights.sbomify.com/CVE-2024-12225/): Io.quarkus:quarkus-security-webauthn: quarkus webauthn unexpected authentication bypass (critical 9.1)
- [CVE-2026-39852](https://insights.sbomify.com/CVE-2026-39852/): Quarkus authorization bypass via semicolon path normalization inconsistency (high 8.8)
- [CVE-2022-0981](https://insights.sbomify.com/CVE-2022-0981/): Privilege escalation in quarkus (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-0044 and fix it if it is affected.

What it is: CVE-2023-0044 is a medium-severity cross-site scripting vulnerability in quarkus-vertx-http, published on 23 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-0044 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.quarkus:quarkus-vertx-http (Maven): affected all versions; fixed in 2.13.7.Final
- io.quarkus:quarkus-vertx-http (Maven): affected all versions; fixed in 2.13.7.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-0044/ (Markdown: https://insights.sbomify.com/CVE-2023-0044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-0044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-0044
- OSV: https://osv.dev/vulnerability/CVE-2023-0044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-0044/
Summaries are generated and may contain mistakes; the official description above is the record.
